[原创]HDU 2222 Keywords Search [AC自动机]【字符串】

2017-02-11 11:49:26 Tabris_ 阅读数:160


博客爬取于2020-06-14 22:41:41
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/54981815


题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=2222

-------------------------------------------------------------------------------------------------------.
Keywords Search

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 59295 Accepted Submission(s): 19490

Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output
Print how many keywords are contained in the description.

Sample Input
1
5
she
he
say
shr
her
yasherhs

Sample Output
3

--------------------------------------------------------------------------------------------------------.
题目大意:就是有n个单词,问你这n个单词在文本中出现的有几个

解题思路:
AC自动机入门题,
多模式匹配

附本题代码
--------------------------------------------------------------------------------------------------------.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
# include <bits/stdc++.h>
using namespace std;

const int kind = 26;
struct node{
node *fail;
node *next[kind];
int cnt;
node(){
fail = NULL;
cnt = 0;
memset(next,NULL,sizeof(next));
}
}*q[500001];

char keyword[51];
char str[1000001];
int head,tail;

void insert(char *str,node *root){
node *p =root;
int i = 0,index;
while(str[i]){
index = str[i]-'a';
if(p->next[index]==NULL) p->next[index] = new node();
p = p->next[index];
i++;
}
p->cnt++;
}

void build_ac_automation(node *root){
root->fail=NULL;
q[head++]=root;
while(head!=tail){
node *temp = q[tail++];
node *p=NULL;
for(int i=0;i<26;i++){
if(temp->next[i]!=NULL){
if(temp == root) temp->next[i]->fail=root;
else {
p = temp->fail;
while(p!=NULL){
if(p->next[i]!=NULL){
temp->next[i]->fail=p->next[i];
break;
}
p = p -> fail;
}
if(p==NULL) temp->next[i]->fail=root;
}
q[head++] = temp->next[i];
}
}
}
}

int query(node *root){
int i=0,cnt=0,index,len=strlen(str);
node *p=root;
while(str[i]){
index=str[i]-'a';
while(p->next[index]==NULL && p!=root) p=p->fail;
p=p->next[index];
p=(p==NULL)?root:p;
node *temp = p;
while(temp!=root && temp->cnt!=-1){
cnt+=temp->cnt;
temp->cnt=-1;
temp=temp->fail;
}
i++;
}
return cnt;
}

int main(){
int _ = 1,kcase = 0;
while(~scanf("%d",&_)){
while(_--){
head = tail = 0;
node *root = new node();

int n;
scanf("%d",&n);
getchar();
for(int i=0;i<n;i++){
gets(str);
insert(str,root);
}

build_ac_automation(root);
scanf("%s",str);
printf("%d\n",query(root));
}
}
return 0;
}