[原创]HDU 4046 Panda [树状数组]【数据结构】

2016-11-08 19:45:07 Tabris_ 阅读数:269


博客爬取于2020-06-14 22:42:47
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/53086391


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4046

---------------------------------------------------------------.

Panda

Time Limit: 10000/4000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3439 Accepted Submission(s): 1113

Problem Description
When I wrote down this letter, you may have been on the airplane to U.S.
We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror. I love your smile and your shining eyes. When you are with me, every second is wonderful.
The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.
I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.
There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.
Saerdna.

It comes back to several years ago. I still remember your immature face.
The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.
Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.
The love letter is too long and Panda has not that much time to see the whole letter.
But it’s easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.
But Panda doesn’t know how many Saerdna’s love there are in the letter.
Can you help Panda?

Input
An integer T means the number of test cases T<=100
For each test case:
First line is two integers n, m
n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000
The next line has n characters ‘b’ or ‘w’, ‘b’ means black, ‘w’ means white.
The next m lines
Each line has two type
Type 0: answer how many love between L and R. (0<=L<=R< n)
Type 1: change the kth character to ch(0<=k< n and ch is ‘b’ or ‘w’)

Output
For each test case, output the case number first.
The answer of the question.

Sample Input
2

5 2
bwbwb
0 0 4
0 1 3
5 5
wbwbw
0 0 4
0 0 2
0 2 4
1 2 b
0 0 4

Sample Output
Case 1:
1
1
Case 2:
2
1
1
0

Source
The 36th ACM/ICPC Asia Regional Beijing Site —— Online Contest

---------------------------------------------------------------.

题目大意:
就是最开始有一个n这么长的串 有m次操作
操作0,L,R,询问L~R中内包含"wbw"的个数。
操作1,k,ch,将第k个字符更换为ch。

解题思路:
就是用树状数组维护一下 ,在“wbw”中以左边为界放到树状数组中就行了。

然后在更换字符的时候
枚举一下几种情况就行了

附本题代码
-----------------------------------------.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
# include <bits/stdc++.h>

# define abs(x) (((x)>0)?(x):-(x))
# define lalal puts("*********")
using namespace std;
/**************************************/
const int N = 50000+5;
# define lowbit(x) (x&-x)
int sum[N],cnt;
void update(int index,int val){
for(int i=index; i<=cnt; i+=lowbit(i)){
sum[i]+=val;
}
return ;
}

int getSum(int index){
int ans = 0;
for(int i=index; i>0; i-=lowbit(i)){
ans+=sum[i];
}
return ans ;
}

char a[N];
int main(){
int _,kc;
while(~scanf("%d",&_)){
kc=0;
while(_--){
memset(sum,0,sizeof(sum));
int n,m;
scanf("%d %d",&n,&m);
cnt=n;
scanf("%s",a+1);
for(int i=3; i<=n; i++){
if(a[i-2]=='w'&&a[i-1]=='b'&&a[i]=='w')
update(i,1);
}
int order,l,r,k;
char ch;
printf("Case %d:\n",++kc);
while(m--){
scanf("%d",&order);
if(1==order){
scanf("%d %c",&k,&ch);
k++;
if(a[k]==ch) continue;
if(k>=3&&a[k-2]=='w'&&a[k-1]=='b'&&a[k]=='w')
update(k,-1);
if(k>=3&&a[k-2]=='w'&&a[k-1]=='b'&&ch=='w')
update(k,1);
if(k>=2&&k+1<=n&&a[k-1]=='w'&&a[k]=='b'&&a[k+1]=='w')
update(k+1,-1);
if(k>=2&&k+1<=n&&a[k-1]=='w'&&ch=='b'&&a[k+1]=='w')
update(k+1,1);
if(k+2<=n&&a[k]=='w'&&a[k+1]=='b'&&a[k+2]=='w')
update(k+2,-1);
if(k+2<=n&&ch=='w'&&a[k+1]=='b'&&a[k+2]=='w')
update(k+2,1);
a[k]=ch;
}
if(0==order){
scanf("%d %d",&l,&r);
if(r-l<2) puts("0");
else printf("%d\n",getSum(r+1)-getSum(l+1+1));
}
}
}
}
return 0;
}