[原创]POJ 2823 Sliding Window [单调队列]【杂类】

2016-10-31 17:37:05 Tabris_ 阅读数:227


博客爬取于2020-06-14 22:42:55
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/52984325


题目链接:http://poj.org/problem?id=2823
--------------------------------.
Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 55854 Accepted: 16062
Case Time Limit: 5000MS
Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value

:::
Window positionMinimum valueMaximum value
[1 3 -1] -3 5 3 6 7-13
1 [3 -1 -3] 5 3 6 7-33
1 3 [-1 -3 5] 3 6 7-35
1 3 -1 [-3 5 3] 6 7-35
1 3 -1 -3 [5 3 6] 736
1 3 -1 -3 5 [3 6 7]37
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input

8 3
1 3 -1 -3 5 3 6 7
Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

-----------------------------------.
题目大意:
就是求长度为n的数列中长度为k的邻近区间的最大值和最小值;

解题思路:
这道题就是单调队列的入门题目
但是据说线段树也可以过 但是不仅代码量大 而且复杂度也不是最优的。

以为这个求得区间与区间之间存在邻近的关系 所以想到用单调队列优化的思路这样的话可以把复杂度降到O(n)

维护的时候只要维护一下下标就行了

单调队列的数组实现其实和尺追法差不多,觉得不好写的话用手过几遍数据强化一下就行.

附本题代码
----------------------.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
# include <cmath>

typedef long long int LL ;
using namespace std;

const int N = 1e6+5;
int a[N];
int deq[N]; //单调队列 维护下标

/*
维护下标和直接维护值 好像并没有什么区别啊
稍加改动就行了
对于在线输出的只要维护一下下标就可以了
离线的话目测还必须把队列给加上。。
*/

int main(){
int n,k;
while(~scanf("%d%d",&n,&k)){

for(int i=1;i<=n;i++)
scanf("%d",&a[i]);

int l,r,flag;

//最小值
l=deq[1]=1,r=flag=0;
for(int i=1;i<=n;i++){

while(l<=r&&deq[l]<=i-k) l++;
while(l<=r&&a[deq[r]]>=a[i]) r--;
deq[++r]=i;

if(i>=k){
if(flag) printf(" ");flag=1;
printf("%d",a[deq[l]]);
}
}
puts("");

//最大值
l=deq[1]=1,r=flag=0;
for(int i=1;i<=n;i++){

while(l<=r&&deq[l]<=i-k) l++;
while(l<=r&&a[deq[r]]<=a[i]) r--;
deq[++r]=i;

if(i>=k){
if(flag) printf(" ");flag=1;
printf("%d",a[deq[l]]);
}
}
puts("");
}
return 0;
}