[原创]hdu 2588 GCD [欧拉函数]【数论】*

2016-08-11 11:48:04 Tabris_ 阅读数:345


博客爬取于2020-06-14 22:43:55
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/52181264


题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=2588
-------------------------.
GCD

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1700 Accepted Submission(s): 829

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample Input
3
1 1
10 2
10000 72

Sample Output
1
6
260
-------------------------.
题目大意 : 不解释

题解:

首先明确的是,要求的gcd(x,N)N\gcd(x,N) |N成立
那么我们只要知道gcd\gcd结果为N的每一个约数时的个数就行了,
[dN]成立,那么就是求gcd(N,x)=d的个数,显然只gcd(N,d)=d,当且仅当gcd(N,dz)=d当[d|N]成立,那么就是求\gcd(N,x)=d的个数,\\显然只\gcd(N,d)=d,当且仅当\gcd(N,d*z)=d

gcd(a,b)>=c 可以转化成gcd(a/c,b/c)=1;

那么gcd(N/d,dz/d)=1gcd(N/d,z)=1\gcd(N/d,d*z/d)=1 \\ \gcd(N/d,z)=1

那么就是 求小于N/d的与N/d互质的数的个数即可,也就是欧拉函数小于N/d的与N/d互质的数的个数即可,也就是欧拉函数

最后答案就是dn,d>=mϕ(d)\sum_{d|n,d>=m}\phi(d)

题目所求的欧拉函数也同理

最后O(sqrt(n)^(3/2))可解决

附本题代码
-----------------------.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
# include <stdio.h>
# include <vector>
# include <iostream>
# include <stdlib.h>
using namespace std;
# define LL long long int
# define pb push_back

int Euler(int n)
{
if(n==1) return 1;
int m=n;

for(int i=2; i*i<=m; i++)
if(m%i==0)
{
n-=n/i;
while(m%i==0)
m/=i;
}
if(m!=1)
{
n-=n/m;
}
return n;
}

int solve(int n,int m)
{
int ans=0;
for(int i=1; i*i<=n; i++)
{
if(n%i) continue;
if(i>=m&&i*i!=n)
ans += Euler(n/i);
if(n/i>=m)
ans += Euler(i);
}
return ans;
}

int main()
{
int _,p=0;
scanf("%d",&_);
while(_--)
{
int n,m;
scanf("%d%d",&n,&m);
int sum=solve(n,m);
printf("%d\n",sum);
}
return 0;
}