[原创]Light 1045 Digits of Factorial 【数论】

2016-06-30 15:54:37 Tabris_ 阅读数:241


博客爬取于2020-06-14 22:44:17
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/51791054


题目链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=120197#problem/U


Digits of Factorial
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Factorial of an integer is defined by the following function

f(0) = 1
f(n) = f(n - 1) * n, if(n > 0)

So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

Input
Input starts with an integer T (≤ 50000), denoting the number of test cases.

Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

Output
For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

Sample Input
5
5 10
8 10
22 3
1000000 2
0 100
Sample Output
Case 1: 3
Case 2: 5
Case 3: 45
Case 4: 18488885
Case 5: 1


题目大意  :  就是求n!在base进制下表示 不算前导0的话 有多少位

多少位的话 直接取log即可
但是n大了 long long 会爆 所以
拆成
log(n!)=log(n)+log(n-1)+ … (以上底数为base).

因为计算机中只有底数为十的对数函数 所以 表示成lg(n!)/lg(base) 就行

最后n==0 的时候要特判一下.


上面就是题解了
但是 我做的时候出现了 迷之RE+迷之WA

RE : printf(“Case %d: %.0llf\n”,++p,f[n]/log(base)+0.5);
这么输出居然是RE

于是又换了一种

WA:printf(“Case %d: %d\n”,++p,(int)(f[n]/log(1.0*base)+0.5));

这样居然是WA ?我就不明白了

最后还是看别人代码 用的ceil() 才过的 但这到底是为什么啊啊啊啊啊啊啊啊啊
最终过得姿势 ::: printf(“Case %d: %d\n”,++p,(int)ceil(f[n]/log(1.0*base)))


附本题代码


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
# include <stdio.h>
# include <stdlib.h>
# include <string.h>
# include <limits.h>
# include <malloc.h>
# include <ctype.h>
# include <math.h>
# include <string>
# include <iostream>
# include <algorithm>
# include <map>
# include <vector>
# include <set>

using namespace std;

# define LL long long int

double f[1001110];


int main()
{
f[0]=0;
for(int i=1;i<=1000010;i++)
{
f[i]=f[i-1]+log(1.0*i);
}

int t,p=0,n,base;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&base);

if(n==0)
{
printf("Case %d: 1\n",++p);
continue;
}
printf("Case %d: %d\n",++p,(int)ceil(f[n]/log(1.0*base)));
}
return 0;
}