[原创]HDU 5326 多维数组接法 【并查集】

2016-01-23 18:40:20 Tabris_ 阅读数:284


博客爬取于2020-06-14 22:45:11
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/50570897


A - Work

Time Limit: 1000 MS Memory Limit: 32768 KB 64bit IO Format: %I64d &
%I64u

Description

**
**

It’s an interesting experience to move from ICPC to work, end my college life
and start a brand new journey in company.

As is known to all, every stuff in a company has a title, everyone except the
boss has a direct leader, and all the relationship forms a tree. If A’s title
is higher than B(A is the direct or indirect leader of B), we call it A
manages B.

Now, give you the relation of a company, can you calculate how many people
manage k people.

Input

There are multiple test cases.

Each test case begins with two integers n and k, n indicates the number of
stuff of the company.

Each of the following n-1 lines has two integers A and B, means A is the
direct leader of B.

**
**

1 <= n <= 100 , 0 <= k < n

1 <= A, B <= n

Output

For each test case, output the answer as described above.

Sample Input

7 2

1 2

2 4

1 3 2 5

3 7

3 6

Sample Output

2

题目就是给了一堆数,分别对应一个人,然后吧就是A领导B,最后让你求出有K个手下的人的个数。(开始翻译成了求K的手下有几个。。英语不好真苦逼啊)。。。

本题其实是一道并查集的题目,但是并查集并没有写明白,所以用了苦逼的多维数组。。。

详情请看代码。。。

然后开始贴代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101

#include <iostream>//本人AC代码  
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int has[2][105][105];  //表示领导关系的成立与否 成立为1 不成立默认是0
int son[105];               //表示第几个人的手下
int n,m,sum;
int  fin(int x)              //核心代码
{
    int num=0;
        for(int j=1; j<=n; j++)
        {
            if(has[1][x][j]==1&&has[0][x][j]==0)
            {
                num++;
                has[0][x][j]=1;
                son[x]+=fin(j);
            }
        }
    return son[x];
}
int main ()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(has,0,sizeof(has));//数组清0
        memset(son,0,sizeof(son));
        int a,aa;
        sum=0;
        for(int i=1; i<n; i++)
        {
            scanf("%d%d",&a,&aa);
            has[1][a][aa]=1;      //表示领导关系
            son[a]++;                 //这里把a的直接手下记录
        }
        for(int i=1; i<=n; i++)   // 这里来计算每个人的间接手下
        {
            for(int j=1; j<=n; j++)
            {
                if(has[1][i][j]==1&&has[0][i][j]==0)   //后面的那个用来标记遍没遍历,不知道到底有没有用 但是这样比较保险
                {
                    has[0][i][j]=1;
                    son[i]+=fin(j);
                }
            }
        }
        //测试的代码   
        /* 
        for(int i=1; i<=n; i++)
        {
            printf("**%d\n",son[i]);
        }
        */
        for(int i=1; i<=n; i++)
        {
            if(m==son[i])
                sum++;
        }
        printf("%d\n",sum);
    }
}


/* 另附几组测试数据
7 6  //1
1 2
1 3
2 4
2 5
3 6
3 7


7 2  //2
1 2
1 3
2 4
2 5
3 6
3 7


7 2 // 2
7 6
7 5
6 4
6 3
5 2
5 1


7 1  //1
1 2
2 3
3 4
4 5
5 6
6 7
*/