[原创]POJ 2318 TOYS [叉积判断+二分查找]【计算几何】

2016-04-05 13:59:34 Tabris_ 阅读数:555


博客爬取于2020-06-14 22:44:42
以下为正文

版权声明:本文为Tabris原创文章,未经博主允许不得私自转载。
https://blog.csdn.net/qq_33184171/article/details/51064266


题目链接:http://poj.org/problem?id=2318

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13008 Accepted: 6269

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
这里写图片描述
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.


题目大意: 有一个方盒子 有N个板隔开 分成N+1个区域
又给了M个玩具的坐标 问你每个区域内(不能恰好在区域内)的玩具有几个(忽略玩具体积)


解题思路: 每相邻的两个板看成两个向量 分别求其与其中一点和玩具坐标的叉积 如果两叉积的乘积<0 就说明这个玩具坐标点在一个板的右边 一个板的左边

因为数据量比较大 可以把板和方盒的两边记录下来 然后二分 道理是一样的


附本题代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
# include <cmath>

using namespace std;
int num[5005],x[5005],y[5005];

int n,m,f=0;

struct point
{
int x,y;
} pu[5005],pl[5005],q;

int mul(point p1,point p2,point p3)
{
return (p2.x-p1.x)*(p3.y-p1.y)-(p3.x-p1.x)*(p2.y-p1.y);
}

void Besearch(point x)
{
int l=0,r=n+1,ans;
while(l<=r)
{
int mid=(l+r)/2;
if(mul(x,pu[mid],pl[mid])<0)
{
ans=mid;
r=mid-1;
}
else
l=mid+1;
}
num[ans-1]++;
}


int main()
{
int x1,x2,y1,y2;
while(~scanf("%d",&n))
{
if(n==0) break;
memset(num,0,sizeof(num));


scanf("%d %d %d %d %d ",&m,&x1,&y1,&x2,&y2);


pu[0].x = x1;
pu[0].y=y1;
pl[0].x = x1;
pl[0].y=y2;
for(int i=1; i<=n; i++)
{
scanf("%d %d",&pu[i].x,&pl[i].x);
pu[i].y=y1,pl[i].y=y2;
}

pu[n+1].x = x2;
pu[n+1].y=y1;
pl[n+1].x = x2;
pl[n+1].y=y2;
/*
for(int i=0; i<=n+1; i++)
{
printf("--->%d-%d %d-%d\n",pu[i].x,pu[i].y,pl[i].x,pl[i].y);
}
*/
for(int i=0; i<m; i++)
{
scanf("%d %d",&q.x,&q.y);
Besearch(q);
/*
for(int j=0;j<n;j++)
{
if(mul(a[j].u,y1,a[j].l,y2,x[i],y[i])*mul(a[j+1].u,y1,a[j+1].l,y2,x[i],y[i])<0)
{num[j]++;break; }
}
*/
}

if(f==1) printf("\n");
f=1;
for(int i=0; i<=n; i++)
printf("%d: %d\n",i,num[i]);

}
return 0;
}